Manual Básico de Conversão de Pseudocódigo (Portugol) para C#
Elaborado por Gabriel Vinicios Silva Maganha – http://gvensi...
Operações Aritméticas Básicas (incremento e decremento):
Pseudocódigo

C#

num <- num + 1

num <- nota * var

num = num + ...
Console
Programas feitos em Console são aqueles que rodam na chamada “tela preta”, do antigo sistema DOS. Ainda hoje
muito...
Próximos SlideShares
Carregando em…5
×

Manual básico de conversão de pseudocódigo para C#

2.045 visualizações

Publicada em

0 comentários
1 gostou
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
2.045
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1.100
Ações
Compartilhamentos
0
Downloads
29
Comentários
0
Gostaram
1
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Manual básico de conversão de pseudocódigo para C#

  1. 1. Manual Básico de Conversão de Pseudocódigo (Portugol) para C# Elaborado por Gabriel Vinicios Silva Maganha – http://gvensino.com.br Regras para nomes de variáveis As regras para identificadores de variáveis (nomes de variáveis) no C# são as mesmas do pseudocódigo. Não pode começar com números nem conter caracteres especiais. Não pode conter espaços. Não podem ter o mesmo nome que uma instrução da linguagem. Tipos de Dados Pseudocódigo Equivalente em C# num : inteiro num : real opcao : caractere nome : literal pagou : logico int num; double num; char opcao; String nome; Boolean pagou; Atribuição de valores à variáveis Atribuição em Pseudocódigo Equivalente em C# num <- 50 num <- 8.5 opcao <- “s” nome <- “Gabriel Vinicios Corinthiano” pagou <- Verdadeiro //Pode ser Falso também num = 50; num = 8.5; opcao = “s”; nome = “Gabriel Vinicios Corinthiano”; pagou = true; // pode ser false também Conversão de tipo de dados A linguagem C# é uma linguagem fortemente tipada. Isso significa que os tipos de dados tem de estar muito bem definidos, para que não hajam erros. Por isso, muitas vezes, precisamos converter de um tipo de dados para outro. O mais comum é convertermos um dado de String para número (int ou double). Veja qual comando usamos para realizar conversões: Converter para: Código int double char String Boolean Convert.ToInt32 ( Convert.ToDouble ( Convert.ToChar ( Convert.ToString ( Convert.ToBoolean ( <<a ser convertido>> ); <<a ser convertido>> ); <<a ser convertido>> ); <<a ser convertido>> ); <<a ser convertido>> ); Operadores Aritméticos, Relacionais e Lógicos do C#: Op. Aritméticos Função Op. Relacionais Função Op. Lógico Função + * / % Soma Subtração Multiplicação Divisão Módulo (resto da divisão) > >= < <= == != Maior Maior ou Igual Menor Menor ou Igual Igualdade Diferença && || ! AND (E) OR (OU) NOT (NÃO)
  2. 2. Operações Aritméticas Básicas (incremento e decremento): Pseudocódigo C# num <- num + 1 num <- nota * var num = num + 1; num++; num = num + 20; num += 20; num = num – 1; num--; num = num – 20; num -= 20; num = nota * var; Estrutura Condicional no Pseudocódigo Equivalente em C# se (idade < 18) então escreva (“Proibido de entrar!”) fimse if (idade < 18){ Console.Write (“Proibido de entrar!”); } se (idade < 18) então escreva (“Proibido de entrar!”) if (idade < 18) { Console.Write (“Proibido de entrar!”); senão escreva (“Seja bem vindo!”) } else { Console.Write (“Seja bem vindo!”); fimse se (idade > 18 e idade < 70) então escreva (“Voto obrigatório”) senão se (idade < 16) então escreva (“Você ainda não pode votar :<”) senão escreva (“Voto facultativo”) fimse fimse } if (idade > 18 && idade < 70) { Console.Write (“Voto obrigatório”); } else { if (idade < 66){ Console.Write (“Você ainda não pode votar :<”); }else{ Console.Write (“Voto facultativo”); } } Estruturas de Repetição no Pseudocódigo Equivalente em C# enquanto a<100 faca //instruções fimenquanto while (a<100){ //instruções } faca //instruções enquanto (a<100) //não funciona no VisualG para var de 0 ate 100 passo 1 faca // instruções que se repetirão 100x fimpara do{ //instruções } while (a<100); for (i=0; i<100; i++){ //instruções que se repetirão 100x } num <- num + 20 num <- num - 1 num <- num – 20 Comentários em C# // Isto é um comentário de apenas uma linha! /* Este comentário tem várias linhas. Começa aqui, ... passa por aqui ... ... e termina aqui! */
  3. 3. Console Programas feitos em Console são aqueles que rodam na chamada “tela preta”, do antigo sistema DOS. Ainda hoje muitos programas existem nesta forma. As desvantagens de se programar desse modo são duas, basicamente: não se pode utilizar o mouse, apenas o teclado; o programa fica feio, com uma aparência antiga. Entretanto, para aprender a programar C#, programar no Console é uma das melhores formas, já que quando usamos a programação gráfica (WindowsForms) muita coisa já vem pronta e o aluno não aprende muito da linguagem em si. Vale lembrar que todo programa feito no console deve estar dentro da função static void Main, assim como na Linguagem C. Principais comandos do Console Pseudocódigo C# escreva ( “oi” ) escreval (“Corinthians!”) leia (nome) // literal leia (parcelas) // inteiro leia (preco) // real leia (sexo) // caractere [m ou f] Console.Write (“oi”); Console.WriteLine (“Corinthians!”); //pula de linha após escrever nome = Console.ReadLine(); //String não precisa de conversão parcelas = Convert.ToInt16 ( Console.ReadLine() ); preco = Convert.ToDouble ( Console.ReadLine() ); sexo = Convert.ToChar ( Console.ReadLine() ); Windows Forms São os programas que utilizam as janelas do Windows. São mais modernos e amigáveis ao usuário, além de geralmente serem mais fáceis de se programar graças à IDE do Visual Studio, que trás um método fácil de construção e Forms através do Drag and Drop (Arrastar e Soltar) componentes. Exemplos com os principais comandos Windows Forms C# MessageBox.Show ("OinEu sou Corinthiano!", "Título da Janela"); // o que será que esse /n faz? if (MessageBox.Show("O Corinthians é o melhor?", "Titulo", MessageBoxButtons.YesNo) == DialogResult.Yes) { MessageBox.Show("Resposta correta!"); }else{ MessageBox.Show("Resposta Errada. Vá estudar!"); } MessageBox.Show("Você digitou " + textBox1.Text + ", não é mesmo?" ); //textbox1 é uma TextBox Application.Exit(); //Fecha todo o programa this.Close(); //desde que não seja o Form Principal Abrindo Outros Formulários: Form2 sou_o_form2 = new Form2(); //cria um objeto chamado sou_o_form2 (nome opcional) sou_o_form2.Show(); // mostra esse objeto na tela, através do método Show() Quer fazer algo diferente? PESQUISE! A internet e o Google estão ai pra isso! Há farto material de C# em português e também em inglês na internet. Delicie-se!

×