Algoritmo 1
Semana 02
PORTUGOL - VISUALG
1
Forma Geral de um Algoritmo
Algoritmo "<nome do algoritmo>"
var
< declaração de variáveis>
inicio
< lista de comandos>
fim...
Forma Geral de um Algoritmo
Algoritmo "<nome do algoritmo>"
var
< declaração de variáveis>
inicio
< lista de comandos>
fim...
Forma Geral de um Algoritmo
Algoritmo "<nome do algoritmo>"
var
< declaração de variáveis>
inicio
< lista de comandos>
fim...
Forma Geral de um Algoritmo
Algoritmo "<nome do algoritmo>"
var
< declaração de variáveis>
inicio
< lista de comandos>
fim...
Forma Geral de um Algoritmo
Algoritmo "<nome do algoritmo>"
var
< declaração de variáveis>
inicio
< lista de comandos>
fim...
Variáveis
São espaços reservados na memória do
computador para guardar informações que
serão utilizadas durante o código d...
Variáveis
Variável
Conteúdo
NomeTipo
Todas as variáveis tem
essas 3 características:
Nome,
Tipo e
Conteúdo
Regras no nome das
variáveis
1. nomes de variáveis não podem ser iguais a
palavras reservadas;
2. nomes de variáveis devem...
Exemplos
Nomes Válidos:
NOME, TELEFONE
IDADE_FILHO
IdadeFilho
NOTA1
Est_Civil
Nomes inválidos:
3Endereco,
Estado Civil,
PA...
Tipos de Dados
Em Português Estruturado, só existem três tipos:
 INTEIRO: Representa valores inteiros Ex:10,5,-5,-10
 RE...
Tipos de Dados
Tipos
Numéricos
Inteiro Real
Literal Lógico
13
Declaração de Variáveis
Var
num1, num2, soma: inteiro
media: real
nome_produto: caractere
Exemplos de Declarações de Variá...
Atribuição
Para atribuir valores às variáveis utilizamos o simbolo de
atribuição
<-
Exemplos:
Peso <- 78.7
Nome <- "João d...
Erros de Atribuição
VAR
salario: REAL
INICIO
salario <- "Insuficiente"
2060 <- NumeroConta
NumeroAgencia+digitoControle <-...
Comentários
 Os comentários são declarações não compiladas
que podem conter qualquer informação textual
que você queira a...
Comandos de Entrada e
Saída
 O comando escreva é utilizado para saída de
dados. Utilizamos o escreva para mostrar instrui...
Comandos de Entrada e
Saída
 Exemplos:
Escreva(“Alô, Mundo!”)
Escreval(“Informe seu nome”)
Escreval(“O valor da soma é”, ...
Comandos de Entrada e
Saída
 O comando leia é utilizado para entrada de
dados. É através deste comando que o usuário
info...
Comandos de Entrada e
Saída
 Antes de fazer qualquer leitura, é necessário
apresentar uma mensagem para o usuário, para
q...
Construindo os primeiros
algoritmos
Algoritmo “Alo Mundo”
Algoritmo Média
 Faça um programa que leia dois valores numéricos, e calcule e
exiba a sua média aritmética.
Algoritmo "C...
Algoritmos 1 - Semana 2
Próximos SlideShares
Carregando em…5
×

Algoritmos 1 - Semana 2

1.050 visualizações

Publicada em

Algoritmos 2 - Semana 2
Introdução ao Portugol

Publicada em: Educação
0 comentários
2 gostaram
Estatísticas
Notas
  • Seja o primeiro a comentar

Sem downloads
Visualizações
Visualizações totais
1.050
No SlideShare
0
A partir de incorporações
0
Número de incorporações
1
Ações
Compartilhamentos
0
Downloads
80
Comentários
0
Gostaram
2
Incorporações 0
Nenhuma incorporação

Nenhuma nota no slide

Algoritmos 1 - Semana 2

  1. 1. Algoritmo 1 Semana 02 PORTUGOL - VISUALG 1
  2. 2. Forma Geral de um Algoritmo Algoritmo "<nome do algoritmo>" var < declaração de variáveis> inicio < lista de comandos> fimalgoritmo
  3. 3. Forma Geral de um Algoritmo Algoritmo "<nome do algoritmo>" var < declaração de variáveis> inicio < lista de comandos> fimalgoritmo Todo algoritmo começa com a Algoritmo, seguido pelo nome do Algoritmo entre aspas. Exemplo: Algoritmo “Soma”
  4. 4. Forma Geral de um Algoritmo Algoritmo "<nome do algoritmo>" var < declaração de variáveis> inicio < lista de comandos> fimalgoritmo Depois do nome do algoritmo, fazemos a Declaração de Variáveis (veremos mais sobre variáveis a seguir...) Exemplos: var num: inteiro nome :caractere localizou: logico salario: real
  5. 5. Forma Geral de um Algoritmo Algoritmo "<nome do algoritmo>" var < declaração de variáveis> inicio < lista de comandos> fimalgoritmo Inicio é a palavra que indica que acabou a seção de declaração de variáveis e o início da seção de comandos <lista de comandos> é somente a representação de onde as instruções de comando ficam no algoritmo. Entre as palavras Inicio e fimalgoritmo
  6. 6. Forma Geral de um Algoritmo Algoritmo "<nome do algoritmo>" var < declaração de variáveis> inicio < lista de comandos> fimalgoritmo fimalgoritmo é a palavra que indica o fim do algoritmo. Perceba que é uma palavra (não tem espaço em branco)
  7. 7. Variáveis São espaços reservados na memória do computador para guardar informações que serão utilizadas durante o código do programa. Podem ter valores de diversos tamanhos e tipos, como: Números Inteiros Números reais Caracteres Datas
  8. 8. Variáveis Variável Conteúdo NomeTipo Todas as variáveis tem essas 3 características: Nome, Tipo e Conteúdo
  9. 9. Regras no nome das variáveis 1. nomes de variáveis não podem ser iguais a palavras reservadas; 2. nomes de variáveis devem possuir como primeiro caractere uma letra ou sublinhado '_' (os outros caracteres podem ser letras, números e sublinhado); 3. nomes de variáveis devem ter no máximo 127 caracteres; 4. Nomes de variáveis não podem conter espaços em branco; 5. na sintaxe do Português Estruturado, não há diferença entre letras maiúsculas de minúsculas (NOME é o mesmo que noMe).
  10. 10. Exemplos Nomes Válidos: NOME, TELEFONE IDADE_FILHO IdadeFilho NOTA1 Est_Civil Nomes inválidos: 3Endereco, Estado Civil, PARA, algoritmo, numero/complemento
  11. 11. Tipos de Dados Em Português Estruturado, só existem três tipos:  INTEIRO: Representa valores inteiros Ex:10,5,-5,-10  REAL ou NUMERICO: Representa valores reais (com ponto separador da parte decimal). Ex: 10, 15.5, -14.67  LITERAL ou CARACTERE: Representa texto (seqüência ou cadeia de caracteres) entre aspas duplas. Ex: "Esta é uma cadeia de caracteres", “B”, “1234”
  12. 12. Tipos de Dados Tipos Numéricos Inteiro Real Literal Lógico 13
  13. 13. Declaração de Variáveis Var num1, num2, soma: inteiro media: real nome_produto: caractere Exemplos de Declarações de Variáveis Var salario_bruto, salario_liquido: real nome_funcionario: caractere idade, quantidade: inteiro
  14. 14. Atribuição Para atribuir valores às variáveis utilizamos o simbolo de atribuição <- Exemplos: Peso <- 78.7 Nome <- "João da Silva" Achei <- FALSO Só devemos atribuir valores do mesmo tipo da variável
  15. 15. Erros de Atribuição VAR salario: REAL INICIO salario <- "Insuficiente" 2060 <- NumeroConta NumeroAgencia+digitoControle <- 2345 + 0
  16. 16. Comentários  Os comentários são declarações não compiladas que podem conter qualquer informação textual que você queira adicionar ao código-fonte para referência e documentação de seu programa. Exemplos // Linha comentada Salario <- 1000 //Atribuição de salario
  17. 17. Comandos de Entrada e Saída  O comando escreva é utilizado para saída de dados. Utilizamos o escreva para mostrar instruir o usuário o que deve fazer e também para mostrar os resultados do algoritmo  No Visualg existem dois comandos escreva com finalidades diferentes quando usado consecutivamente.  Escreval (<expressão ou identificador ou constante>) //Mostra o primeiro resultado na mesma linha depois em linhas diferentes.  Escreva (<expressão ou identificador ou constante>) //Mostra o resultado na mesma linha, mas em colunas diferentes.
  18. 18. Comandos de Entrada e Saída  Exemplos: Escreva(“Alô, Mundo!”) Escreval(“Informe seu nome”) Escreval(“O valor da soma é”, soma) Escreval(“O valor de x:”,x, “y:”,y) Escreval(“A soma é:”, x+y)
  19. 19. Comandos de Entrada e Saída  O comando leia é utilizado para entrada de dados. É através deste comando que o usuário informa (digita) informações para serem utilizadas pelo programa  Sintaxe: Leia (<identificador>)  Exemplos: Leia(NumeroConta) Leia(NumeroAgencia) Leia(NomeCliente)
  20. 20. Comandos de Entrada e Saída  Antes de fazer qualquer leitura, é necessário apresentar uma mensagem para o usuário, para que ele saiba o que fazer: Escreva ("Digite seu nome: ") Leia (nome) Escreva ("Digite sua agencia: ") Leia (NumeroAgencia) Escreva ("Digite sua conta: ") Leia (NumeroConta)
  21. 21. Construindo os primeiros algoritmos Algoritmo “Alo Mundo”
  22. 22. Algoritmo Média  Faça um programa que leia dois valores numéricos, e calcule e exiba a sua média aritmética. Algoritmo "Cálculo de Média Aritmética“ VAR A,B,Media : REAL Inicio Escreval("Programa que calcula a média aritmética de dois valores.") Escreval("Digite um valor : ") Leia (A) Escreval("Digite outro valor : ") Leia (B) Media <- (A+B)/2 Escreval("A média dos dois valores é : ", Media) FimAlgoritmo

×